하위 브라우저 호환, IE Tester로 확인하자!

2014. 1. 2. 12:32
저자 : Kurien

인터넷 브라우저 환경이 늘어나고, 웹 언어가 늘어나면서 크로스 브라우징이 점차 힘들게 됩니다.

이러한 상황에서 가장 큰 문제점은 역시 인터넷 익스플로러입니다.


른 브라우저의 경우 사용 도중 업데이트가 나오면 자동으로 업데이트가 되기 마련인데,

한국에서 가장 많이 사용한다는 인터넷 익스플로러는 XP의 경우 8까지만 지원,

그마저도 설치하지 않아 익스플로러 6을 사용하는 분들도 계시더군요.


근처의 PC방만 가더라도 윈도우 XP를 사용하는 곳이 많아서 하위 브라우저를 쓰는 경우가 대다수입니다.

XP는 더 이상의 업데이트 마저 없구요.


어쩌겠나요, 우리가 맞춰줘야지.

익스플로러를 버전별로 여러개를 설치 하지 않고도 확인 할 수 있는 방법이 있습니다.

바로 IE Tester입니다.


IE Tester로 자신의 웹페이지, 블로그 등의 호환성을 알고 수정할 수 있게되죠.

간단한 사용방법을 알려드려보겠습니다.



먼저 위의 버튼을 눌러서 다운로드 받아서 실행해주세요.



설치 프로그램이 시작되셨나요?

라이센스에 대한 동의를 물어보네요.

I Agree를 눌러주세요!



다른건 만지실 필요 없고, Languages 앞의 +를 눌러 Korean 빼곤 전부 지워주세요!

다른 언어 사용하실꺼라면!? 놔두셔도 되구요.

설치는 여기까지가 끝이네요;;

끝난줄 모르고 왜 안되나 했네요 ㄷㄷ;



실행을 하게 되면 "한글"로 이런 창들이 나오게 됩니다.

깔끔하고 좋네요!

저는 오른쪽 위에 있는 여러IE를 눌러서 사용했습니다.



자신의 블로그 & 웹페이지 주소를 적어주시면 됩니다.

위에 적혀있는 숫자들이 각 IE의 버전이구요.

제일 뒤에 D라고 적혀있는 이건 현재 PC에 설치된 IE의 버전입니다.

9 이상부터는 대부분 호환되구요.

5는 현재 거의 쓰이지 않습니다.

6~8까지가 주로 봐야할 부분이네요.



먼저 IE6로 제 블로그를 확인한겁니다.

다 깨져버리죠?

그래서 IE 8 이하에서 접속하시면 블로그가 정상적으로 보이지 않는다고 적어뒀습니다.

IE 사용자를 배려해줄만큼의 시간이 없네요ㅋ



IE 7은 멀쩡하게 보이나? 싶지만, 사이드바가 아래쪽에 위치해버립니다.

이건 금방 수정이 가능할 것 같으니 수정 해봐야 겠네요.



IE 8부터는 정상적으로 보이지 않을 수도 있다고는 적었지만, 사실 여기부터는 블로그를 보시는데 지장이 없을껍니다.

이것도 힘들게 해놨었는데, IE 좀 멸종했으면 좋겠네요.



마지막 IE9입니다.

여기부터는 전부 제대로 보이니 9까지만 적었습니다.

보시면 IE Tester 창의 크기에 맞게 본문과 사이드 바가 조절됩니다.


IE Tester로 간단하게 확인이 가능합니다.

이제 수정할 방법은 여러분의 몫이죠^^ ㅋ

질문은 댓글에 남겨주시면 확인하는대로 답변 달아드릴꼐요!

  1. Estoque 2014.01.03 11:42 신고  댓글주소  수정/삭제  댓글쓰기

    저는 하위지원은 포기한 상태라 깨지는 부분은 ie옵션으로 전부 안뜨게 만들어 놓았습니다.

    본문이랑 광고만 뜨면 된다는 주의라서 ㅋㅋㅋ

    IE tester 같은경우 윈도에서는 문제 없이 사용가능하지만 저 같은 경우 OS X에서 주로 개발을 하는데, 비슷한 프로그램 조차 없어서 필요할때마다 윈도우로 부팅해야 하는 점이 많이 불편합니다. ㅠㅠ

    • Kurien 2014.01.03 12:05 신고  댓글주소  수정/삭제

      저도 하위 지원은 포기해버렸네요.
      방문자가 아쉽지만 그 부분까지 지원하긴 귀찮거든요.
      저도 리눅스로 수정할땐 귀찮아 죽겠어요
      Wine으로 사용할 수 있을지도 모르긴 하겠는데 귀찮네요...

  2. 7949 2014.01.16 10:57  댓글주소  수정/삭제  댓글쓰기

    하위 IE버젼에 맞게해주다보면, 마이크로소프트가 정말 싫어지더라구요 ㅠㅠ
    XP도 IE9이상으로 업데이트가능하게 해주면, 어디 덧나는것도 아니고;;